New Posts New Posts RSS Feed - Video device errors
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Video device errors

 Post Reply Post Reply
Author
runellord37 View Drop Down
Newbie
Newbie


Joined: 16 Mar 2013
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote runellord37 Quote  Post ReplyReply Direct Link To This Post Topic: Video device errors
    Posted: 14 Apr 2013 at 1:01pm
I bought a machine back in February.
I have an i7 3770k
8 gigs of ddr3 ram
7200 rpm 1tb hd
7970 saphire gpu.

The first video card game DOA. I got the second video card, and I updated to the newest AMD drivers.  Games will get strange textures, almost like tearing from time to time and then it will crash.  Or at times, I will play and everything will be working fine and it will crash. Temps are fine while it does this. I have recently reseated my card. I found in my bios the power was sent on power saver. I put it on optimal. I don't know if this will help. I checked the voltage on my 7970 and it is getting 1.70-75 full load. I have run Fur and CCRT and I got no errors.  The temps are fine. I don't know what is going on, but I have had 19 video errors in windows performance since I got this card. I got zero when I was running on the integrated video on the i7.  I ran a ram tester and all of the ram came back okay. 

Is the 7970 not a stable card?  I sure hope this card isn't dieing. If it is I will not be happy here folks. 
Back to Top
runellord37 View Drop Down
Newbie
Newbie


Joined: 16 Mar 2013
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote runellord37 Quote  Post ReplyReply Direct Link To This Post Posted: 14 Apr 2013 at 4:17pm
I wanted to give an update in case there are others here like me. I put my card in a new pci e slot. I also made sure performance mode was enabled in my bios. I looked in the event viewer and I was having printer driver issues with kodak printer. I removed my print drivers. I also removed my sound blaster x i suround pro sound card from the usb,and I am back to using integrated audio.   I ran 3d mark 2011 for an hour. I ran the stalker cop benchmark for an hour, and I am currently running heaven 2011 benchmark for the second hour now. I also installed 13.3 beta amd drivers. I have not had a single crash in these demanding benchmarks. I wonder if the problem lies with the games themselves. The new Tomb Raider maxed runs fine for me. The games I have had issues with are Crysis 3, bioshock infinite, star craft 2 hots, defience and rift. I don't think it is a problem with my hardware. I think the heaven benchmark which pushes my pc to its limit is doing fine. I am wondering if it s a problem with the games itself. I have been looking on the net and lots of people wer having smiliar issues with the games. Anyone have any ideas?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

  • Call of Duty: Black Ops 4
  • Apex Legends
  • Fortnite
  • GTA V
  • Battlefield V
  • Playerunknown's Battlegrounds
  • Division 2
  • World of Warcraft
  • CS:GO
  • Rocket League
  • Battlefield 1
  • Witcher 3
  • League of Legends
  • Shadow of the Tomb Raider
  • Far Cry 5
  • Overwatch
  • Assassin's Creed: Odyssey
185 Based on 1080P
130 Based on 1440P
NA
Click here to know more
3DMark Time Spy is a popular and effective benchmarking tool for rating gaming performance. Frame rate figures show typical performance as tested by UL. The higher the frame rate and 3DMark score, the better the experience. Performance may change with system, driver, and game updates.
Hello
Our systems indicate you are located in  .
CyberPowerPC can ship to UK via our UK website.
Would you like to access that region's site?
X