New Posts New Posts RSS Feed - Radeon R9 290 Display driver conflict?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Radeon R9 290 Display driver conflict?

 Post Reply Post Reply
magialuna View Drop Down

Joined: 21 Dec 2013
Location: United States
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote magialuna Quote  Post ReplyReply Direct Link To This Post Topic: Radeon R9 290 Display driver conflict?
    Posted: 22 Dec 2013 at 1:33am

I've never made one of these "tech-y" forum posts, so I'm not sure how specific to be--or even if anyone will even ever see it.

I have a Windows 7 Home Premium 64 machine, that will not load the Video driver. I've tried in every way I can think of to install it. ATI has this software "package"-Catalyst- they insist you use but I've managed to locate which file is the driver and separate it out and just install it separately and it doesn't work alone either. No matter what I do, the software loads...Windows requests to restart and then I get a black/gray screen. From what I've read on the Radeon boards it's some sort of indicator that either something is incompatible or something has timed out. Different people seem to have found a few ways to solve *their* issues, but those fixes don't help me. ATI just issued a new driver a couple of days ago which actually says it solves THIS issue, but it does not for me.

Any ideas on where I could look? Specific things to look for that might be annoying the driver? I have GPU-Z installed and it lets me look at the Video card's bios, so it *must* be plugged in and on, or I couldn't see it. And sometimes my computer can see it, it just doesn't want to work. No idea why... so there must be something incompatible with it. I'm running my bios as SATA AHCI, and UEFI/LEGACY (I think that's it, I may have switched the letters, I'm tired and it's all starting to look the same and the book for the motherboard is across the room at the moment) so it's not that issue where things won't boot because only legacy is turned on.

(You all probably know what I mean even if I switched a letter or two since from what I've read the last week or two, there are a lot of computer hobbyist geniuses running around who overclock and delete from Regedit with abandon--these things make me quite nervous, honestly.)

Boy the *things* I have learned about Bios in the last week...

[Edit- Wow, now I know I'm tired, I put the comment about switching letters after the wrong paragraph. I realized I might have used the acronym incorrectly and tried to explain I'm brain fried and am obviously too brainfried to do that. Sorry...-C]

Any assistance would be greatly appreciated.



CAS: Corsair Carbide 300R w/ USB 3.0 [+27]

CPU: AMD FX-9590 4.70 GHz (5.0GHz Turbo) Eight-Core AM3+ CPU 8MB L2 Cache & Turbo Core Technology

FAN: Cooler Master Seidon 120M Liquid Cooling CPU Cooler - Enhance Cooling Performance (Dual Standard 120MM Fans (Push-Pull) [+9])

HDD: 2TB (2TBx1) SATA-III 6.0Gb/s 64MB Cache 7200RPM HDD (2TB x 2 (2TB Capacity) Raid 1 High Performance with Data Security [+133])

MEMORY: 16GB (8GBx2) DDR3/1866MHz Dual Channel Memory (ADATA XPG V2 [-88])

MONITOR: * 24" Widescreen 1920x1080 ASUS VS247H-P 1080P (23.6" Viewable) 2ms LED Backlight, DVI, HDMI Input

MOTHERBOARD: * GIGABYTE 990FXA-UD3 AMD 990 ATX w/ Ultra Durable 3, On/Off Charge, GbLAN, 4 PCIe x16, 2 PCIe x1, 1 PCI

VIDEO: AMD Radeon R9 290 4GB GDDR5 PCIe 3.0 x16 Video Card

Edited by magialuna - 22 Dec 2013 at 1:38am
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Our systems indicate you are located in  .
CyberPowerPC can ship to UK via our UK website.
Would you like to access that region's site?