New Posts New Posts RSS Feed - GeForce RTX 2080 Ti - artifacts, crashes
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

GeForce RTX 2080 Ti - artifacts, crashes

 Post Reply Post Reply
Author
bulacawa View Drop Down
Newcomer
Newcomer


Joined: 09 Oct 2016
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote bulacawa Quote  Post ReplyReply Direct Link To This Post Topic: GeForce RTX 2080 Ti - artifacts, crashes
    Posted: 03 Aug 2019 at 8:33pm
I just got a new computer from CP. The computer will randomly crash, and here's significant artifacts at times, right when the computer boots up (and shows the MB logo), and it continues once logged into windows. The device manager will show that there's an issue with the video card. I've uninstalled it, reinstalled it (including clean install), but yet, sooner or later (sometimes after an hour or so, sometimes sooner), the screen will freeze for 30 or so seconds, and sooner or later the computer will just crash, and reboot with all the artifacts.
I've installed latest drivers and firmware (for motherboard, video card, chip set, etc). I've also removed the video card and put it back in place. Nothing seems to help. I actually just connected an old 1080 GTX and so far no artifacts or crashes...
This is my system:
 AMD RYZEN 9 3900X processor
ASUS ROG STRIX X570-E  Motherboard
850 WATTS - CORSAIR RM SERIES RM850 Power Supply
MSI GEFORCE RTX 2080 TI 
Windows 10 Operating system
1TB GIGABYTE AORUS (PCIE GEN4) NVME M.2 SSD Operating system HD
64 GB CORSAIR 16GB DDR4-3200 VENGEANCE LPX x4
LG 34GK950F is the monitor

Is it the video card? Or could anything else be the cause? Is it maybe an issue with the monitor and the 2080 ti? One interesting piece of information: I took pictures of my phone of the screen with all the vertical artifact lines...but when I take a snippet with the windows tool it won't show the lines.

Any help is much appreciated. Thanks!
Back to Top
bulacawa View Drop Down
Newcomer
Newcomer


Joined: 09 Oct 2016
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote bulacawa Quote  Post ReplyReply Direct Link To This Post Posted: 03 Aug 2019 at 10:27pm
Just wanted to add, I connected the new computer (with the RTX 2080 TI to another monitor and it'll show artifacts there as well as soon as I turn the computer on....so I assume it's the video card and i should ask for a replacement?
Back to Top
coachnitro View Drop Down
Newcomer
Newcomer


Joined: 27 Jul 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote coachnitro Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2019 at 5:56pm
I just ordered as well and received similar issues. When I get to windows screen and look at Device Manager it shows that video card isn't work. GIGABYTE NVIDIA GEFORCE RTX 2080 TI GAMING OC 11GB is the card I purchased with my new machine and in windows I see Error 43 or something. I contacted CP and they were extremely helpful. They will send you a new card, but you have to have a credit card with the funds which they will reimburse. I was similar to you, I put a 1070 in and works great. I also put the 2080 ti in my other PC and it gave me the same errors. I hope that's helpful.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Hello
Our systems indicate you are located in  .
CyberPowerPC can ship to UK via our UK website.
Would you like to access that region's site?
X